Wednesday, August 6, 2008

Dead Camera

Hello all, just letting you know my 40D has kinda died for now........It locked up with "Error 99" yesterday. Thankfully I have a back up camera that works sometimes (it also gives error 99 every now and then) so you will probably still be seeing a few pictures over the next few weeks. I sent my 40D to Canon for repairs and they are saying about 10-14 day before I get it back.......

Till next time, Mr. Snapped it

11 comments:

Jessica Courter said...

I feel for you... I can't imagine life with out a SLR :)

Merritt Eaton said...

O no I'm sorry to hear that!!

Leah said...

Sorry about that, "Mr.Snapped-It". :P That's really unfortunate..

sarah m said...

Our friend's 40D had that same error and he got a new one on warrenty. Hope it gets fixed quickly!

Anonymous said...

hope your surviving with out your right arm:) lol! hope you get it back soon.

tiff

Johan said...

Ouch! My friend's 20D has that same error all the time, but my 10D just freezes up for a second sometimes, but it never says "Error". BTW, what is your backup?

Anonymous said...

We're having a moment of silence for you down here , hope you get it fixed soon. - John Det Ruth Det & Mike Byler

The Chmelars said...

miss your pictures seth! how did that lunch outing go. maybe we can talk tonight.
tiff

Nicole said...

yup... missing you here in china too!
can you post anything?! :)

Marlene Kisling said...

Sorry for you! Hope you can up and running again...

Peter Ort Photography said...

wow sorry dude....

but alot of canon's have that error.... my Nikon hasn't ever had any problems! :P

you shoulda gotten a Nikon... ... ...